Building Blender 2.81 with OpenImageDenoise activated

Howdy friends.

I build my own Blender 2.81 daily. I tried using the OpenImageDenoise node but it seems deactivated by default. Anyone knows how I can build Blender with OpenImageDenoise activated?

My current build steps in Windows are:

Copy to clipboard

make update
make release

Thanks a ton!


on my linux compiled version OIDN work fine, my recipe is:

make deps
make update
make full release

Hey NiCapp. I tried

make deps

But it is not an option in Windows. I hope some one will share their Windows experience here.


IOID builds with Blender and the flag is in CmakeLists file, u don’t have to build it yourself.

option(WITH_OPENIMAGEDENOISE “Enable the OpenImageDenoise compositing…”

This is from their website,check your CPU instructions that’s probably the reason why the Node is deactivated.

Your CPU must support at least SSE4.1 to run Open Image Denoise,

1 Like

Thanks Zinio. I like building myself instead of downloading and then deleting the old version and adding the new download daily build.

The CPU works fine with OpenImageDenoise. I’ve used the daily builds from it works great for denoising.

I just want to build it myself.


The libs you have are the same libs the build bot uses, so there’s no reason to be building them your self.

In your build folder you should have a CMakeCache.txt file, open it up in a text editor and look for this snippet

//Enable the OpenImageDenoise compositing node

and validate that it is indeed on.

Thanks LazyDodo. I found it on


And indeed was OFF. Changed it to ON and now compiling. Will report the result in case someone else has the same question.


Well, I built it again after changing OPENIMAGEDENOISE to ON inside


Unfortunately the Denoise composition node still says

Disabled, built without OpenImageDenoise

How else can I troubleshoot this?


Try deleting your complete build folder and see if it works it self out.

After deleting the folder and re-building, the OpenImageDenoise node is active!