Building Blender 2.8 ends up with errors on windows 10 and Linux (CentOS 7)

I’m building blender 2.8 each couple of days since several month, After correctly setting up by build environments the builds ran mostly without problems on both OS types, Windows 10 (VS2017) and CentOS 7.

On windows some times a “make release 2017” failed but when I deleted the “build_windows_Release_x64_vc15_Release” folder, and build from scratch everything worked fine.

The steps I’m doing every time are:
On Linux :
make update
make full
On Windows:
make update
make release 2017

(using cuda version 9.1 )

Now since 2 days neither a windows 10 nor a Linux build (make full ) run through.
On both OS the make runs ended with (different) errors. Deleting the build folders didn’t fixed it (both Win and Linux). By the way I havn’t updated vs2017, and I didn’t changed my build environment on the CentOS machine

Before going into details with log messages and all that, I wanted to ask if there’s a general known problem at the moment (or a step I missed) which may cause theese failures ?

Thanks in advanvce for your answers :slight_smile:

On Windows things were broken yesterday due to library upgrades, but that should be working again now. I don’t know about Linux, something may have been temporarily broken there as well.

on windows it can be one of two things (or it can be both of these actually)

  1. You have old libraries, update them from svn by running ‘make update’

  2. There was a change in one of the defaults WITH_SYSTEM_OPENJPEG used to be off now it’s on for windows, however since it’s a default it is only set on the initial project creation, any already existing projects will have the old and now incorrect default. when you deleted your build folder the situation corrected it self.

Ok, thank you.

On Windows, I checked out the dependencies again, and after that the build was successful !

On Linux I have again the problem that compilation of OSL stuff failed, but till now this caused only OSL support to be disabled for cycles, the overall build was successful anyway. Is there a change too, so that I have to change some settings to avoid to try compiling OSL ?

if you don’t need it, you can add --skip-osl to and it will not try to build it.

I would like to get it to work, but with no success so far, don’t know why … was the only component which made problems on CentOS 7. But thanks anyway for your hint. I will try to use this option to see wether it helps to get a successfull build of blender


After succesfull run of “ --skip-osl” I tried another
make full
It fails on building “extern_ceres”

… a lot of notes about wrong argument types and warnings about incompatible pointer types …

[ 67% ] Built target extern_ceres
make[1]: *** [ all] Error 2
make: *** [all] Error 2

I got this error on windows 10, since yesterday night, and making it impossible to compile :

CMake Error at CMakeLists.txt:1483 (message):

  Set the cache entry 'PYTHON_INCLUDE_DIR' to point to a valid python include
  path.  Containing Python.h for python version "3.7"

-- Configuring incomplete, errors occurred!
See also ".../build_windows_Release_x64_vc15_Release/CMakeFiles/CMakeOutput.log".

And at the end of the file I got this “CMakeOutput.log” :

1 Warning(s)

0 Error(s)

Time Elapsed 00:00:00.78

Return value: 1
Source file was:

		#include <emmintrin.h>
		int main(void) { __m128d v = _mm_setzero_pd(); return 0; }

so yeah update your libs, and start with a fresh build folder and you should be fine.

1 Like