Build on Linux: Error: GLEW version 2.0 and above is required


#1

Hello,
Trying to compile 2.80 on Linux (CentOS). Everything is building without error but I can’t launch Blender and I get this error:
Error: GLEW version 2.0 and above is required.

the “make deps” command build a glew folder into lib/linux_x86_64 and it seems to be correctly build. And I execute this Blender build on Manjaro Linux that have Glew 2.1 installed and the error message remains the same.

What should I do to execute Blender correctly?


#2

You can see which GLEW library is configured to be used in CMakeCache.txt.

By default it uses the one bundled with Blender, with the setting WITH_SYSTEM_GLEW=OFF. If that is somehow ON for you, you can try setting it to OFF.


#3

It was set to ON. Turning it to OFF makes the build work!
Thank you!