Bug or feature: moving VSE moviestrip over playhead chokes UI

I have a 2.3G mp4-file which I need to cut up for social media purposes on my (windows) :


When I move the moviestrip outside of the playhead, all is fine:

However, when it touches the playhead, things become unworkable and makes blender crash silently at unexpected moments:

I tried proxies, caching e.g., but it doesn’t really help.
Is this a bug? Or does the realtime preview playhead need some second thoughts?

ps. system info: https://pastebin.com/9haGLjjk

ps2. how to reproduce: use a mp4 movie, or use the cmdline ffmpeg command, and just concatenate a mp4 X times until it becomes around 2.4G.

Is prefetch on? If it is, do you get the same result with it off? (Second redundant sentence included to hit the minimum 20 character limit)

I just checked and this is a known issue that is planned to be fixed as part of the on going VSE 2.0 project. See the 6th checkbox in the following task.


awesome, next time I will search in developer.blender.org.
Thanks for the quick help, turns out I can just sit back and simply wait :smiley:
Until then I’ll handle the playhead with care :slight_smile:

1 Like