Developer Forum

Blender switching to object mode automatically

Hi all, so for a few days I have noticed blender switches to object mode from edit mode automatically without any prompt. Has anyone experienced this issue or is it something that I might need to look into? I am using blender 3.0.1

edit: ah, never mind. I just realized that your problem is the other way around.

Is it directly after creating and object?
Because there is a setting for that in
preferences ā†’ Editing ā†’ New Objects ā†’ Enter Edit Mode

1 Like

Could also be default workspace, I remember few years ago I was going crazy because of it.
Basically, every layout has a different workspace

image

4 Likes

Thank you very much for your feedback. So I have tried both methods and they donā€™t seem to be providing me with the desired result. I presume it might have to do with the KitOps Pro addon I installed so I might try to reset my preferences and see if that will work.

Is this happening to you when you change from one object to another or does this happens while you are working on a single object?

It happens while I am working on a single object then if I have another object in the scene it will switch to that one and out of edit mode