3.0 will not run on Mac

On IMac, 2019, running Big Sur 11.3.1, 16GB, Radeon Pro Vega 20 GPU, Intel 6-Core i7 Processor
I have tried MANY builds of the experimental and daily Mac builds of Blender 3.0 , both Intel and ARM(?), no matter what I cannot run/open the app even though I get no error messages or crashes…the icon just bounces then stops.
2.93 was a breeze to install and run.
I have no clue what to do, really need to use 3.0

Run /path/to/Blender.app/Contents/MacOS/Blender in terminal and share the error you get there.

I saw this yesterday–regarding addons–and i have no idea how to remedy?

Read prefs: /Users/geraldineerman/Library/Application Support/Blender/3.0/config/userpref.blend


Warning: ‘SJPhaserPanel’ does not contain ‘PT’ with prefix and suffix

You are not in the correct directory.

Expected: /Users/geraldineerman/Library/Application Support/Blender/3.0/scripts/addons/animation_nodes

Got: /Users/geraldineerman


mv "/Users/geraldineerman/Library/Application Support/Blender/" "/Users/geraldineerman/Library/Application Support/Blender_backup/"

and then open Blender. If it doesn’t open, use the same terminal method again and share the error.

Also, see if there’s any crash file corresponding to time of crash in ~/Library/Logs/DiagnosticReports/ https://docs.blender.org/manual/en/dev/troubleshooting/crash.html#macos

OMG that worked…THANK YOU